We deployed a backend fix for the errors affecting OpenAI models and have confirmed that error rates returned to normal. Users can resume normal usage; no Factory CLI or Desktop update or other action is required.
Posted Aug 07, 2026 - 21:14 UTC
Update
To mitigate the issue, users encountering 431 errors should update to Factory CLI `0.188.0` or newer, or Desktop `0.145.0` or newer
Posted Aug 07, 2026 - 18:49 UTC
Update
We continue to investigate 431 errors from OpenAI models. We advise temporarily switching to non-OpenAI models for uninterrupted workflow.
Posted Aug 07, 2026 - 18:32 UTC
Monitoring
OpenAI models may return 'Error: 431 status code (no body)'. We are in communication with OpenAI and awaiting resolution.